Brotli Decoder Flaw CVE-2026-111497 Triggers Critical Patches Across Microsoft, Node.js, and Python

A critical out-of-bounds write vulnerability in Google’s Brotli compression library, identified as CVE-2026-111497, has prompted emergency security updates from Microsoft, Node.js, and Python maintainers. Dubbed 'Node2Shell' or 'Broccoli2Shell,' the flaw allows unauthenticated attackers to execute arbitrary code or leak memory by sending crafted compressed data to affected decoders. While no active exploitation has been reported in the wild, Imperva demonstrated successful remote code execution on official Node.js images. Microsoft, Node.js, and Python have released patches, with Microsoft rating the issue as 'Exploitation More Likely.' Organizations are advised to update affected runtimes, rebuild container images, and restart services to mitigate the risk.
Key points
- CVE-2026-111497 is an out-of-bounds write in Google’s Brotli decoder, affecting versions 1.0.3 through 1.2.0, with a CVSS v4 score of 9.2.
- Microsoft patched .NET, Visual Studio, and PowerShell on October 25, rating the flaw as critical for .NET and Visual Studio, and important for PowerShell.
- Node.js, Python, Bun, Envoy, and Istio have released fixes, with Node.js crediting OpenAI Codex Security for discovering the issue during red-teaming.
- Imperva demonstrated remote code execution on the official Node.js 24.22.0 Linux arm64 image, though no active exploitation has been reported in the wild.
- Unpatched software includes DuckDB, Apache Arrow, and 7-Zip-zstd, and organizations must rebuild container images and restart services to apply fixes.
Background
This vulnerability emerged from a flaw discovered by OpenAI in February 2026 but not recognized as a security issue until October 2026. The bug was fixed in the Brotli source code in February, but no release shipped with the fix until now, requiring downstream projects to issue their own updates. The vulnerability affects any application that processes attacker-controlled Brotli-compressed data, including HTTP requests, responses from untrusted servers, and compressed files. It is part of a broader trend of critical vulnerabilities in compression libraries, following earlier issues like PHP2Shell and LiteLLM supply chain attacks.
How outlets are covering it
SecurityWeek and Rapid7 emphasize the critical nature of the flaw and the urgency of patching, with Microsoft rating it as 'Exploitation More Likely.' Wiz highlights the widespread exposure in cloud environments, noting that 91% of cloud environments have vulnerable resources. Aikido Security focuses on the technical details of the flaw and the need to rebuild container images, while Imperva provides proof-of-concept exploits. OpenAI credits the discovery to its Codex Security team, and the Node.js project notes that the fix predates the disclosure. Some researchers argue the bug can only be used for denial-of-service attacks, but Imperva and others have demonstrated code execution.
Why it matters
The vulnerability affects a wide range of widely used software, including Microsoft’s .NET, Node.js, Python, Bun, Envoy, and Istio, making it a critical risk for organizations relying on these technologies. The potential for remote code execution and memory disclosure means that unpatched systems could be compromised by unauthenticated attackers. The widespread use of Brotli in HTTP compression and other data processing means that many applications may be exposed without explicit knowledge. Organizations must prioritize remediation to prevent potential exploitation, especially given the critical CVSS score and Microsoft’s assessment of exploitability.
What to watch
Organizations should immediately update affected software to patched versions, including Node.js 22.23.4, 24.22.1, and 26.12.1, Python’s Brotli 1.2.1 and brotlicffi 1.2.1.0, and Microsoft’s .NET 8.0.33, 9.0.22, and 10.0.14. They should also rebuild container images and restart services to ensure the patched code is loaded. For platforms without vendor fixes, such as Ubuntu and SUSE, organizations can use Aikido’s patched container images or disable Brotli decompression. Monitoring for suspicious Brotli-compressed traffic and anomalous process behavior is recommended, and organizations should continue to track updates from vendors and security advisories.
- Node2Shell: Brotli Flaw Triggers Patching Across Microsoft, Node.js, Python Packages SecurityWeek
- Broccoli2shell: Everything You Need To Know About The Critical Brotli Decoder Vulnerability wiz.io
- CVE-2026-111497: Critical out-of-bounds write in the Node.js Brotli decoder Rapid7
- Node2Shell Brotli vuln (CVE-2026-111497) evolves to HTTP2Shell, as libraries and apps using HTTP are affected. Aikido Security
- Brotli Decoder Flaw Behind Node.js RCE Also Affects Bun, Python and Other Widely Used Software The Hacker News
Want the full story? Read the original reporting
Read on SecurityWeek